[Dwarf-discuss] PROPOSAL: Constant expressions in locations lists

Cary Coutant cary at cup.hp.com
Fri Apr 27 10:48:03 PDT 2007

> This proposal looks like a good idea to me.  You use two different
> names, DW_OP_implicit_value and DW_OP_constant_value.  I definitely
> prefer the later (these are also sometimes called manifest  
> constants or
> static constants, see http://en.wikipedia.org/wiki/ 
> Variable#Constants).

Oops. I started with DW_OP_constant_value, but Ron argued  
persuasively (in an email dated 3/14/07) that implicit_value was a  
better name:

>> DW_OP_constant_value feels like it is on the right track. Other  
>> names that might be less confusing vis-a-vis the current  
>> DW_OP_const* operators might be DW_OP_immediate_value or  
>> DW_OP_known_value or DW_OP_implicit_value (now just where did that  
>> Thesaurus go...). I like the name DW_OP_implicit_value personally  
>> because it does sort'a suggest that there is no specific place  
>> where that value can be found (or replaced).

I meant to change it throughout, but I'm OK with either name.

> Do we want DW_OP_constant_value1, DW_OP_constant_value2,
> DW_OP_constant_value4, and DW_OP_constant_value8 which indicate fixed
> sized constants for 1, 2, 4 and 8 bytes?  There is certainly precedent
> for this in DWARF and they would be very commonly used.

Sounds reasonable to me.


More information about the Dwarf-Discuss mailing list