[Dwarf-Discuss] Older version of libdwarf on new Linux error 48 (stamp version error)

Paul Redkoles paul.redkoles@gmail.com
Fri Jun 3 03:32:09 GMT 2022

I have an older version of libdwarf (over 10 years). And I'm building it on
Oracle 79 with the Intel 2020 compilers.
Everything compiles clean (libdwarf and exe that uses the lib), but I'm
getting error #48 when calling dwarf_next_cu_header().
This is the dw_dle_version_stamp_error.
The stamp version is set to 2 in the lib.
Any idea what could be wrong?

This same release of libdwarf works on suse Linux 11 (2013) using Intel
2016 compilers.  I left all makefiles for libdwarf and the exe that uses
the lib, the same when migrating to new setup.  Again All builds clean.

Both machines are Intel xeon 64-bit os.

I've also tried newer versions of libdwarf, but enough has changed that it
broke the code that uses the older libdwarf. But I did proceed down that
path as well. And this code can't be changed.

I've tried lots of things with not a lot of success.

What's strange is, if I run the binary (built on the older machine) on the
newer machine, libdwarf works fine.

Hopefully this is enough clues for some things I could try. ??

Many thanks.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.dwarfstd.org/pipermail/dwarf-discuss-dwarfstd.org/attachments/20220602/d1301983/attachment.html>

More information about the Dwarf-discuss mailing list