[Dwarf-discuss] DWARF Issue 030812.2
Mon Jun 13 19:04:42 GMT 2005
On Mon, Jun 13, 2005 at 06:47:32PM -0400, Daniel Jacobowitz wrote:
> Re: <a href=http://dwarf.freestandards.org/ShowIssue.php?issue=030812.2>DWARF Issue 030812.2</a>
> I think that val_cfa_offset would be clearer than val_offset; every time
> I see val_offset, I'm going to ask myself, "offset from what?".
I used val_offset because it's an alternative to offset, which already
is defined. That is,
offset: CFA+offset is the location where the value is stored
val_offset: CFA+offset is the value itself
So, if val_offset is going to make you ask that, then doesn't the existing
offset make you ask the same question? I admit these names get confusing.
It seems like almost all of the instructions contain one of the terms cfa or
offset, or both. (Every time I come across DW_CFA_def_cfa_offset, I think my
head is going to explode. :-) ). But I doubt we really want to go back and
change the name of the existing offset rule or its instructions. And I think
the symmetry of names is useful in order to keep the confusion from getting
completely out of control.
I know that adding an extra cfa into the instruction names probably would
confuse me into thinking it was one of the DW_CFA_def_cfa_* instructions at
some point in the future, after I've had a chance to forget all this again.
Concurrent Computer Corporation
More information about the Dwarf-discuss