[Dwarf-discuss] DWARF Issue 030812.2

Daniel Jacobowitz drow
Mon Jun 13 19:08:22 GMT 2005

On Mon, Jun 13, 2005 at 05:04:06PM -0600, Todd Allen wrote:
> On Mon, Jun 13, 2005 at 06:47:32PM -0400, Daniel Jacobowitz wrote:
> > Re: <a href=http://dwarf.freestandards.org/ShowIssue.php?issue=030812.2>DWARF Issue 030812.2</a>
> > 
> > I think that val_cfa_offset would be clearer than val_offset; every time
> > I see val_offset, I'm going to ask myself, "offset from what?".
> > 
> I used val_offset because it's an alternative to offset, which already
> is defined.  That is,
>    offset:     CFA+offset is the location where the value is stored
>    val_offset: CFA+offset is the value itself
> So, if val_offset is going to make you ask that, then doesn't the existing
> offset make you ask the same question?  I admit these names get confusing.

I confess that it does.  However, offset has slightly better internal
consistency: it's a rule, defining an offset for a saved register.  So
having it relative to the CFA makes good sense.  But the CFA is an
awfully arbitrary thing for the value to be offset from.

> I know that adding an extra cfa into the instruction names probably would
> confuse me into thinking it was one of the DW_CFA_def_cfa_* instructions at
> some point in the future, after I've had a chance to forget all this again.

Good point.  *shrug* guess we're confused either way.

Daniel Jacobowitz
CodeSourcery, LLC

More information about the Dwarf-discuss mailing list